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2. Introduction 

 

The goal of this manual is to cover the CASINO 3.3 program in depth. Note that 

CASINO is rapidly growing and the current document might not be totally compatible 

with the most current release. 

 

Font Conventions 

This manual uses the following typographical conventions: 

Italic 

 Used for filenames, pathnames 

Constant width 
 Used for menu names, dialog titles, and dialog labels 

Constant width bold 
 Used for text that would be typed by the user 
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3. Creating a Simulation 

Quickly creating a new simulation is one of the strong points of the CASINO software. A 

few dialogs will quickly provide the necessary information to generate a simulation.  

 

Starting the simulation 

A new simulation wizard is available through the File->New menu or the New 
Simulation icon.  

 
This wizard will guide you through three dialogs to setup a simulation. For each dialog, 

the user can Cancel the setup, Finish the setup, or go to the Previous or Next 

dialog. 

 
The three dialog are Edit Layers, Microscope and Simulation Properties, 

and Distributions with the corresponding icons: Edit Sample Layers, 

Microscope SetUp, and Distributions. 
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Creating the sample 
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4. Create Sample Dialog 

 

 
 

In this dialog you can add multiple objects to the sample. Possible objects are simple 

planes that can be used to delimit a new region, boxes, truncated pyramids, spheres, 

cylinders, cones and rounded rectangles. You can change their properties with the “M” 

icon (modify) or by double clicking on them. You can also apply different actions to 

them like merging with the substrate, cutting with the substrate or translating them. 

 

 These actions can be applied to more than one object at the same time by 

selecting more than one of them using the shift key and the mouse. When more than one 

object is selected and the modify command is chosen, the modify dialog for each item 

will be called one after each other when the modify dialog for the current item is closed. 

This was done since each object has different properties so it did not make sense to be 

able to change them all at the same time. 
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Important notes: 

 

CASINO works the following way: when an electron crosses an object surface, a 

collision is detected. To determine the new region of the electron, the surface has an 

inside and an outside value determined in the Layers dialog. This way, if the box in the 

example (see the Create Sample Dialog screenshot) is made of Aluminium inside and of 

empty space outside, an electron passing through it from the top will be detected as being 

in empty space when leaving the box, when in fact it is in the substrate (the box is half 

over the substrate and half under the substrate)! The solution to this problem would be to 

cut the box in 2 with the “Cut by Substrate” button, and then the portion inside the 

substrate could have outside value different from the outside portion.  

 

Another problem will arise. The two boxes surfaces are in the same plane as the 

substrate. This will cause an electron passing from one region to the other to miss one of 

the borders. For example, an electron coming from the top, passing through the 

Aluminium box, and then into the substrate will detect the collision with the box border, 

effectively passing from Aluminium into empty space, but the entrance into the substrate 

will NOT be detected. The solution to this problem is to use the “Place over Substrate” or 

“place under Substrate” button. This will create a very small empty space between the 

box and the substrate.  

 

The ‘Substrate size’ option can be used to specify the size of the substrate. It will 

also be the sample size. You can also specify whether or not you want to use a substrate 

by ticking the ‘Use substrate’ box.  

 

The ‘Wireframe’ option is used to display the sample showing only the 

wireframe. This can be used to see through objects that would otherwise hide other 

objects from you. 

 

You can also apply a translation to one or more object by selecting them and right 

clicking on them and choosing ‘Translate’ or going to the Edit menu and clicking on 

‘Translate’. A dialog will then ask you the translation to apply to the objects. 
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Modify Sample Object Dialog 

 

 
 

Name: Name of the object that you will be able to refer to when assigning a chemical 

composition to it later. 

 

Region: ?? 

 

Translation: Position of the object in the X,Y,Z coordinates system, negative Z being 

upward. 

 

Rotation: A rotation in respect to the X, Y or Z axis will be applied to the object 

(numbers are in degrees) 

 

Scale: For planes and other similar objects this is the size of the object; for a sphere the 

scale will be multiplied by its radius so should be kept to 1. 

 

Change Color: Pop up a dialog where you can change the color of the object. 
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Edit Layers Dialog 

 

 
 

In this dialog you can import a sample from a 3DS files, create a new sample, 

modify an existing one (explained in the last section) or assign a chemical composition to 

each regions.  

 

Like explained in the last section, casino use an inside and an outside region for 

each objects. To simplify the entering of the same composition to multiple regions, they 

can be merged using the ‘Merge Selected Layers’ option. To unmerge them in case you 

change your mind and need to change the composition of a region that is merged with 

others, you need to click on create or modify and regenerate the sample. All regions will 

then be unmerged. 

 

You can also import models made with professional graphic programs such as 3D 

Studio Max™1 by importing files in the 3DS format with the Import command. The 3DS 

format is supported by many different programs, some of them are free.  

                                                 
1 http://www.discreet.com/ 

http://www.discreet.com/
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To specify or change the composition of a region, double click on them to get to 

the Layer Chemical Composition Dialog. 

 

Layer Chemical Composition Dialog 

 

 
 

Name: Name of the composition. 

 

Composition: In this dialog you can enter the composition of a region. Just enter 

the chemical formula in the Composition text area and you should see casino trying to 

recognize the elements. A green check will be next to an element recognized by 

CASINO and a red cross if it is not (In the example above you can see that a typo has 

been done and CASINO cannot recognize the element). 

 

Density: If you do not specify a density, casino will try to calculate it for you but it 

is not always really accurate. A better way is to manually specify a density (in 

g/cm3). 

 

The weight fraction/atomic fraction can also be specified manually if the 

automatically calculated values are not what you want. 
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Virtual Element can also be used if you want to specify manually the average Z and 

A of the region instead of using the calculations made by casino. 

 

Add to library: When you are satisfied with a region you can add it to the region 

library by clicking on add to library. You can later get back the same region by typing 

it’s name in the Name box and if the region name exist in the library it will ask you if 

you want to replace the current composition with the one in the library. 

 

Color: Ask a new color for the region. 
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5. Microscope and Simulation Properties Dialog 

 

 
 

This dialog can be used to set up the different options of the beam. You can use the 

toolbar (on the left in the image) to select if you want a single point, a line scan or an 

image. 

 

The spacing between points and the size of the pixel can be specified in the Electron 

Beam Properties group on the right. 

 

Number of simulated electrons: Specify the number of electrons that will be 

simulated with each scan points. 

 

Conserve Data for each simulated point:  If you want to use the distributions of 

the CASINO program, you must conserve the data for each point. It will take a 

tremendous amount of memory though.  
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Simulate Noise: Simulate noise in the number of electrons simulated. Use shot noise to 

model a Poisson distribution of the number of electrons per scan points and percentage if you 

want a fixed percentage of noise to be simulated. 

 

Generate Secondary Electrons: Will use the secondary electrons model to simulate 

secondary electrons. A box will also be displayed asking if you want to set the physical 

models to Monsel2 settings. 

 

Generate X-Rays: Broken in CASINO 3 for the moment. 

 

Advanced Beam Properties: To enable advanced properties, click on the advanced 

properties box. Else default value of a XY scan and a perfectly straight beam will be used. 

 

Beam Semi-angle: Semi-angle of the beam. 

 

Scanning properties: Specify whether the scan is in the XY, XZ or YZ plane. A value 

can also be specified for the third coordinate. 

 

Beam distribution: Model for the distribution of the electrons in the beam. Electrons can 

either be distributed uniformly across the beam area or using a Gaussian distribution. 

 

Sample Angle: To simulate an electron beam with an angle, it is possible to make the 

sample rotate in a specified axis.  

 

 

 

                                                 
2 Lowney JR, Marx E: Semiconductor Measurement Technology: User’s Manual for the 

Program MONSEL-I: Monte Carlo Simulation of SEM Signals for Linewidth Metrology. 

Nist Special Publication 400-495, USPGO, Washington, D.C. (1994) 

 

Lowney JR: MONSEL-II: Monte Carlo Simulation of SEM Signals for Linewidth 

Metrology. Microbeam Anal 4, 131-136 (1995) 
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6. Distributions Dialog 

 

 
 

 

Distributions: Many distributions are provided with CASINO. They simplify the 

analysis of the results and are mostly used to evaluate the outcome of a future experiment 

with a real microscope.  

 

The first column is used to specify the number of points in the distribution. Also 

you can enable only the distribution that interest you so you don’t need to pay the cost in 

memory for the one you don’t want. 

 

Collect data logarithmically: You can set this option for the distribution you want the 

data to be collected logarithmically. 

 

Max Range Parameter: Settings used to determine the min and max value for the 

distribution. CASINO can try to automatically deduce the correct range to collect the data 

but the user can use the ‘Fixed’ option to manually enter values. Even when using the 

‘Fixed’ option, user can choose individual values to be auto-calculated by casino by 

entering auto in the textbox. 
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Distribution of Energy: The distribution of the energy can be collected using 

cartesian, spherical or cylindrical coordinates. You can then set the corresponding size 

and number of divisions for each dimension.  

 

You can also specify if the position of the center of the energy matrix is in 

absolute coordinate or relative to the scan point. 

 

The view to the right can also be used to view the look of the energy matrix 

compared to the sample. 
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7. Toolbar explanation 

 
The icons are grouped from left to right in the following groups: 

 File management 

 Copy and export current display results 

 Simulation options 

 Advanced simulation options 

 Results display settings 

 Running simulation control 

 Graphic scale settings 

 

 Create a new simulation wizard. It will pass through all the necessary steps to create 

a new simulation. 

 

 Open a simulation file stored in a .sim (not simulated yet) or .cas (simulation with 

results) file type. 

 

 Save a simulation to a .sim (not simulated yet) or a .cas (simulation with results) file 

type.  

 

 Copy data to clipboard. 

 

 Copy display (image) to clipboard. 

 

 Save the display (image) into a bitmap (.bmp) file. 

 

 Save the data currently displayed into a text file (.dat). 

 

 Create sample and edit the region compositions. It must be done before the 

simulation begins. 

 

 Setup microscope options. They must be setup before the simulation begins. 

 

 Select distributions to compute. They must be set before the simulation begins. 

 

 Setup CASINO runtime options related to the simulation options that are not saved in 

the .sim or .cas file. 

 

 Launch the physical models selection dialog. 
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 Settings related to the annular dark field (ADF) detector. 

 

 Settings related to the main 3D display. 

 

 Settings related to the distributions display. 

 

 Settings related to the Energy by Position distribution 

 

 Settings related to the Intensity distribution. 

 

 Launch the visualisation toolbar. Useful to manipulate the main sample view camera. 

 

 Launch the simulation. 

 

 Pause the simulation. Clicking on it a second time or clicking on play will launch 

back the simulation where it was stopped.  

 

 Stop the simulation. The simulation will be terminated.  

 

 Auto resize the display scale. 

 

 Manual resize of the display scale. 

 

 Launch About CASINO dialog. 
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8. CASINO Main Dialog Menu Overview 

File 

File->New Start the new simulation wizard. It will pass through all the necessary steps 

to create a new simulation. 

 

Open... Open a simulation file stored in a .sim (not simulated yet) or .cas (simulation 

with results) file type. 

 

Open Sample... Open a sample file stored in a .sam file type. Need to setup 

simulation options before starting the simulation. 

 

Open Options... Open a simulation options file stored in a .cop file type. Need to 

create sample before starting the simulation. 

 

Open Sample and Options... Open a simulation file stored in a .sim file type. 

 

Close Simulation Close the currently selected simulation. 

 

Save Save the current selected simulation with the same file name. 

 

Save As... Save the current selected simulation as a simulation file stored in a .sim 

(not simulated yet) or .cas (simulation with results) file type. 

 

Save Sample... Save a sample file stored in a .sam file type. 

 

Save Options... Save a simulation options file stored in a .cop file type. 

 

Save Sample and Options... Save a simulation file stored in a .sim file type. 

 

Four (4) recent files are available for quick opening. 

 

Exit Quit CASINO. 

 

Edit 

Edit->Copy Display Copy the display (image) into the clipboard. 

 

Edit->Copy Data Copy the data currently displayed into the clipboard. 

 

Edit->Export Display Save the display (image) into a bitmap file (.bmp). 

 

Edit->Export Data Save the data currently displayed into a text file (.dat). 
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View 

View->Adjust Scale Launch the User Defined Scales dialog for settings the 

scales of graphic results display. 

 

View->Auto-Adjust Scale Automatically adjust the scales of graphic results display. 

 

Simulation 

Simulation->Run Start the simulation. 

 

Simulation->Pause Pause/resume the simulation. 

 

Simulation->Stop Stop the simulation. 

 

Settings 

Settings->Modify Sample Launch the Edit Layers dialog for creating/setting the 

sample. 

 

Settings->Set Up Microscope Launch the Microscope and Simulation 
Properties dialog for settings related to the microscope and simulation properties. 

 

Settings->Select Distributions Launch the Distributions dialog for 

settings related to the distributions calculated by CASINO. 

 

Advanced Settings 

Advanced Settings->Runtime Option Launch the Options dialog for settings 

related to the simulation options that are not saved in the .sim or .cas file. 

 

Advanced Settings->ADF Sensor Settings Launch the ADF Sensor 
Settings dialog for settings related to annular dark field (ADF) detector. 

 

Advanced Settings->Change Physical Models Launch the Select Physics 
Model dialog for settings related to the physical models used by CASINO. 

 

Display 

Display->Display Options Launch the Display Options dialog for settings 

related to the main 3D display. 

 

Display->Distribution Display Options Launch the Graph Options dialog 

for settings related to distribution graphic display. Mostly the 2D graphic display options. 
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Display->Energy Distribution Display Options Launch the Energy 
Distribution Display Options dialog for settings related to energy distribution 

graphic display. 

 

Display->Intensity Distribution Display Options Launch the Intensity 
Graph Properties dialog for settings related to the scan points spot, line scan, and 

image options display. 

 

Help 

Help->About wincasino... Launch About CASINO dialog. 
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9. Select Physics Model Dialog 
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CASINO can simulate many different physical models. The default settings are 

quite optimal for most users, but it is possible to use many different models that might 

have different strengths.  

 

One point to notice is that CASINO has integrated the Monsel program in a 

contract with the NIST and can now simulate ionisation and plasmon secondary electrons 

thanks to the Monsel algorithms. Not every model is compatible with the Monsel 

algorithms. More particularly, the continuous energy loss in Monsel must be Joy & Luo 

modified by Lowney. 

 

Secondary Electron Fine Tuning: 

 

Minimum electron energy (no secondary electrons generation): The current 

state of the energy loss models cannot permit us to simulate electrons at energy lower 

than 0.05 KeV. At energy lower than that, the energy loss curve become positive and 

generates an energy gain.  

 

Minimum Order of SE Generated: CASINO puts a limit on the maximum order of a 

generated electron. Putting this setting too low will limit the secondary yield as each 

energy level has a decreasing impact on the secondary yield.  

 

Residual energy loss: Lowney made some modifications to the Joy & Luo model of 

energy loss. These modifications include a fixed energy loss. The impact is minimal at 

energies higher than 0.05 KeV if the loss is small, but it prevents positive energy loss at 

lower energy.  

 

Minimum electron energy: The minimal energy when using the Lowney model for 

energy loss is the working function of the element in the region of the collision. It is still 

possible to override the working function and specify a different value. If the minimum 

electron energy has a value equal or lower than 0 will make CASINO use the working 

function instead of the override value. 

 

Minimum generated secondary electron energy: Like the minimum electron 

energy, this setting overrides the working function value. It corresponds to the minimal 

energy a secondary electron can have when it is generated.  
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10. Runtime Option Dialog 

 

 
 

Here are many options related to the CASINO program. These options can greatly 

affect the performance (in calculation time) of the simulation and thus, the user is 

encouraged to try different settings. 

 

Number of displayed trajectories: If you have an older / slower video card, you can 

reduce the number of trajectories displayed (mostly when generating secondary electrons, 

the screen will get clogged with secondary electrons trajectories). It will also affect 

memory consumption if you only conserve displayed trajectories.   

 

Time between Status Bar Refresh: Time interval that the status bar will be 

refreshed while simulation is running. 

 

Number of CPU used: If your system has multiple CPUs/cores, CASINO can create 

many threads to use more than one.  You should usually put this to the number of cores in 

your system. This option can be changed on the fly while the simulation is running and 

the number of core used should respond accordingly. 

 

Number of scan points per thread: When simulating scan points with few electrons, 

it can happen that the thread creation/destruction take a noticeable chunk of time 

compared to the time spend simulating. If you notice that you have put the ‘Number of 

CPU used’ option to the number of core in your system and CASINO is not using all of 

you CPU, try putting a higher number here (you will need to restart the simulation if you 

want it to take effect). 
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Conserve electrons trajectories: The simulation trajectories take a lot of memory 

space. As of now, it is thus impossible to conserve all the information in every trajectory. 

You can choose to save all of them, only the number of trajectories displayed (see 

corresponding option) or none at all. 

 

Thread priority level: Priority for the calculation threads (should normally be set to 

below normal or even idle so it doesn’t clog your CPU when other application needs it. It 

will still use the maximum of it if other applications don’t use it). 

 

11. ADF Sensor Settings 

 

 
 

Enable ADF Sensor: Enable the Transmitted Electron Detector. 

 

Keep trajectories angle to allow post-simulation recalculation: This option 

enable the user to change the Detector Semi-Angle and Detector Quantum Efficiency 

parameters after the simulation and see the new results without having to do the whole 

simulation again. This will cost some memory. 

 

Maximum number of points used when keeping angles: Number of points used 

when keeping angles. Angles are calculated between 0 and PI/2 so this is the number of 

points in the distribution of the angles. A higher number will add some precision but cost 

memory so you should try to put a small number while keeping a reasonable precision. 

 

Detector Quantum Efficiency: Simulate the detector quantum efficiency by throwing 

a random number and comparing it with this value for each angles before considering it 

has detected. 

 

Detector Semi-Angle: Semi-angles of the detector. 
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12. Display options Dialog 

. 

 
 

 

This dialog can be used to specify some options for the display of the sample and 

trajectories. You can choose to highlight all backscattered electrons, choose the color of 

the trajectories, show collisions or change the sample display to wireframe. The opacity 

of the sample can also be adjusted here so you can see through it. 

 

You can also choose to invert the mouse X or Y axis and change the sensitivity of 

it or the mousewheel. 
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13. Graph Options Dialog 

 

 
 

In this dialog you can specify some parameters relating to how the graphs are 

displayed in CASINO.  

 

Graph Type: Specify the type of graph: histogram, a continuous line, points or vertical 

lines. 

 

Number of tabs: specify the number of tabs in the axis. 

 

Normalize data: Specify if you want the data normalized by the total number of 

electrons in each scan points (detected electrons divided by the total number of simulated 

electrons) or only the raw data in electrons. 
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14. Energy by Position Distribution Options Dialog 

 

 
 

Here you can specify some options relating to the energy by position distribution. 

 

Sum over the projected axes: This options sums all the planes in the third 

dimension (i.e. when using the XZ view, it will sums all values from the Y planes) 

 

Diffuse: specify whether to display the raw energy by position distribution or the one 

with the diffusion model. 

 

Normalize with the volume: This option is used when using the spherical/cylindrical 

coordinates so that the energy values are normalized with the volume of each boxes (this 

has no effects in the cartesian distribution since all boxes have the same volume) 

 

Carrier surface recombination: Parameter for the diffuse model (not implemented 

yet) 

 

Projection: specify to display the 2D view of the energy by position matrix by XZ or 

XY, or view a 3D view of the matrix. 

 

Y plane / Z plane: when the ‘Sum over the projected axes’ is unticked, specify which 

plane to display. 

 

Visible Energy: Used in the 3D view of the energy by position display. 
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Region / Carrier Diffusion Length: Specify the carrier diffusion length parameter for 

the diffusion model for each region. Changing this parameter should force the diffused 

energy distribution to be recalculated. 

 

15. Intensity Graph Properties Dialog 

 

 
 

Here you can set the parameters related to the intensity display. 

 

Intensity: Choose which type of data you want displayed. 

 

Display Mode: Choose if you want the data to be displayed in 3D or 2D (only for 

images). 

 

Scale Coloration: Choose the color you want the data to be displayed (images only). 

 

Regions with check boxes: Used to specify which region you want the energy 

intensity to be displayed (only for Absorbed Energy / Absorbed Energy with Diffusion). 

 

Max / Min: Specify the Max and Min value for the intensity display with the option to 

automatically calculate it. For example, if you specify a Max value lower than the 

maximal data, all values higher than Max will be clipped. 
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16. Results 

 

Deposited Energy Distribution 

The exported deposited energy distribution values are in keV. No normalization was done 

before exporting the data. 
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17. How should I cite CASINO in a scientific paper? 

Use the following article to reference CASINO: 

H. Demers, N. Poirier-Demers, A. Réal Couture, D. Joly, M. Guilmain, N. de Jonge, and 

D. Drouin. (2011). "Three-dimensional electron microscopy simulation with the 

CASINO Monte Carlo software." Scanning 33(3): 135-146. 
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18. Licenses 

This program uses the following software libraries: boost, smart_ptr, ezLogger, libtiff, 

ResizableLib, and TreeCtrlEx. The copyright notices and license information for each are 

given below or see licenses folder. 

 

Boost 

 

Boost Software License - Version 1.0 - August 17th, 2003 

 

Permission is hereby granted, free of charge, to any person or organization 

obtaining a copy of the software and accompanying documentation covered by 

this license (the "Software") to use, reproduce, display, distribute, 

execute, and transmit the Software, and to prepare derivative works of the 

Software, and to permit third-parties to whom the Software is furnished to 

do so, all subject to the following: 

 

The copyright notices in the Software and this entire statement, including 

the above license grant, this restriction and the following disclaimer, 

must be included in all copies of the Software, in whole or in part, and 

all derivative works of the Software, unless such copies or derivative 

works are solely in the form of machine-executable object code generated by 

a source language processor. 

 

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, 

EXPRESS OR 

IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF 

MERCHANTABILITY, 

FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN 

NO EVENT 

SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE 

SOFTWARE BE LIABLE 

FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT 

OR OTHERWISE, 

ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE 

USE OR OTHER 

DEALINGS IN THE SOFTWARE. 

 

smart_ptr 

 

SmartPtrLicense License 

Copyright (C) 2005-2005 by David Maisonave (Axter) 

This software library is free.\n 

Permission to use, copy, modify, distribute this software 

and its documentation for any purpose is hereby granted without fee, 
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provided that the above copyright notice appear in all copies. 

David Maisonave (Axter) makes no representations 

about the suitability of this software for any purpose. 

It is provided "as is" without express or implied warranty. 

 

ezLogger 

 

David Maisonave (Axter) (609-345-1007) (www.axter.com) 

Copyright (C) 2006 

 

libtiff 

 

Copyright (c) 1988-1997 Sam Leffler 

Copyright (c) 1991-1997 Silicon Graphics, Inc. 

 

Permission to use, copy, modify, distribute, and sell this software and  

its documentation for any purpose is hereby granted without fee, provided 

that (i) the above copyright notices and this permission notice appear in 

all copies of the software and related documentation, and (ii) the names of 

Sam Leffler and Silicon Graphics may not be used in any advertising or 

publicity relating to the software without the specific, prior written 

permission of Sam Leffler and Silicon Graphics. 

 

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY 

KIND,  

EXPRESS, IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, 

ANY  

WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR 

PURPOSE.   

 

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR 

ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES OF 

ANY KIND, 

OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA 

OR PROFITS, 

WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON 

ANY THEORY OF  

LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR 

PERFORMANCE  

OF THIS SOFTWARE. 

 

ResizableLib 

Source code can be downloaded at http://sourceforge.net/projects/resizablelib/. 
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The Artistic License 

 

Preamble 

 

The intent of this document is to state the conditions under which a Package  

may be copied, such that the Copyright Holder maintains some semblance of  

artistic control over the development of the package, while giving the users of  

the package the right to use and distribute the Package in a more-or-less  

customary fashion, plus the right to make reasonable modifications. 

 

Definitions: 

 

  * "Package" refers to the collection of files distributed by the Copyright  

    Holder, and derivatives of that collection of files created through textual  

    modification.  

  * "Standard Version" refers to such a Package if it has not been modified,  

    or has been modified in accordance with the wishes of the Copyright Holder.  

  * "Copyright Holder" is whoever is named in the copyright or copyrights for  

    the package.  

  * "You" is you, if you're thinking about copying or distributing this  

    Package.  

  * "Reasonable copying fee" is whatever you can justify on the basis of media  

    cost, duplication charges, time of people involved, and so on. (You will not  

    be required to justify it to the Copyright Holder, but only to the computing  

    community at large as a market that must bear the fee.)  

  * "Freely Available" means that no fee is charged for the item itself,  

    though there may be fees involved in handling the item. It also means that  

    recipients of the item may redistribute it under the same conditions they  

    received it. 

 

1. You may make and give away verbatim copies of the source form of the  

   Standard Version of this Package without restriction, provided that you  

   duplicate all of the original copyright notices and associated disclaimers. 

 

2. You may apply bug fixes, portability fixes and other modifications derived  

   from the Public Domain or from the Copyright Holder. A Package modified in such  

   a way shall still be considered the Standard Version. 

 

3. You may otherwise modify your copy of this Package in any way, provided  

   that you insert a prominent notice in each changed file stating how and when you  

   changed that file, and provided that you do at least ONE of the following: 

 

  a) place your modifications in the Public Domain or otherwise make them  

     Freely Available, such as by posting said modifications to Usenet or an  

     equivalent medium, or placing the modifications on a major archive site such  

     as ftp.uu.net, or by allowing the Copyright Holder to include your  
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     modifications in the Standard Version of the Package. 

   

  b) use the modified Package only within your corporation or  

     organization. 

   

  c) rename any non-standard executables so the names do not conflict with  

     standard executables, which must also be provided, and provide a separate  

     manual page for each non-standard executable that clearly documents how it  

     differs from the Standard Version. 

 

  d) make other distribution arrangements with the Copyright Holder. 

 

4. You may distribute the programs of this Package in object code or  

   executable form, provided that you do at least ONE of the following: 

 

  a) distribute a Standard Version of the executables and library files,  

     together with instructions (in the manual page or equivalent) on where to get  

     the Standard Version. 

   

  b) accompany the distribution with the machine-readable source of the  

     Package with your modifications. 

   

  c) accompany any non-standard executables with their corresponding Standard  

     Version executables, giving the non-standard executables non-standard names,  

     and clearly documenting the differences in manual pages (or equivalent),  

     together with instructions on where to get the Standard Version. 

   

  d) make other distribution arrangements with the Copyright Holder. 

   

5. You may charge a reasonable copying fee for any distribution of this  

   Package. You may charge any fee you choose for support of this Package. You may  

   not charge a fee for this Package itself. However, you may distribute this  

   Package in aggregate with other (possibly commercial) programs as part of a  

   larger (possibly commercial) software distribution provided that you do not  

   advertise this Package as a product of your own. 

 

6. The scripts and library files supplied as input to or produced as output  

   from the programs of this Package do not automatically fall under the copyright  

   of this Package, but belong to whomever generated them, and may be sold  

   commercially, and may be aggregated with this Package. 

 

7. C or perl subroutines supplied by you and linked into this Package shall  

   not be considered part of this Package. 

 

8. The name of the Copyright Holder may not be used to endorse or promote  

   products derived from this software without specific prior written  
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   permission. 

 

9. THIS PACKAGE IS PROVIDED "AS IS" AND WITHOUT ANY EXPRESS OR 

IMPLIED  

   WARRANTIES, INCLUDING, WITHOUT LIMITATION, THE IMPLIED 

WARRANTIES OF  

   MERCHANTIBILITY AND FITNESS FOR A PARTICULAR PURPOSE. 

 

The End 

 

TreeCtrlEx 

 

CTreeCtrlEx - Multiple selection tree control for MFC 

 

Copyright © 1997-2003 Bendik Engebretsen 

bendik@techsoft.no 

http://www.techsoft.no/bendik/ 

 

http://www.techsoft.no/bendik/
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